Web Captue operation you have requested failed because of an error

When open a web link (https) in Acrobat Pro
It keeps say
"Web Captue operation you have requested failed because of an error"
Is there some setting that needs to be changed?


ying wang


5 Answers

This is the second time I am hearing about a problem with converting SSL (https) web pages to PDF in a couple of days. I am not aware of a general problem, and on my systems, I can convert https based web pages (both Mac and Windows).

What operating system are you using? Can you reproduce this problem with a very simple web page (e.g. https://google.com)?

Karl Heinz Kremer
PDF Acrobatics Without a Net
PDF Software Development, Training and More...
http://www.khkonsulting.com


Karl Heinz Kremer   

Acrobat Pro can open https://www.google.ca

I have a map link can open by Adobe Reader but not Acrobat Pro.

In Acrobat Pro has error as "Web Capture operation you have requested failed because of an error"

I find out there is not https issue.

The issue is the URL contains special characters such as < in Query string.
the sample query string like maprequest=<mapRequest><layer id="67" where="CUSTOMER_CUSTOMER_ID in (682)" inextent="Y" /></mapRequest>


ying wang   

I use Window 7 as OS


ying wang   

Take a look at RFC3986, which defines how URI's (or URL's need to be formatted):

http://www.ietf.org/rfc/rfc3986.txt

Characters that are allowed in a URI but do not have a reserved
purpose are called unreserved. These include uppercase and lowercase letters, decimal digits, hyphen, period, underscore, and tilde.

You will have to percent-encode the "<" and ">" characters. Here is more about character encoding in URLs:

http://www.blooberry.com/indexdot/html/topics/urlencoding.htm

Karl Heinz Kremer
PDF Acrobatics Without a Net
PDF Software Development, Training and More...
http://www.khkonsulting.com


Karl Heinz Kremer   

When open the link from Adobe Reader, it can automatically apply the encoding.
Why Acrobat Pro can not do it? Is there any settings to allow automatically apply the encoding?


ying wang   


Please specify a reason: