'The font 'LucidaGrande' contains a bad /BBox.' Error when opening OCR'd documents with Acrobat XI Pro on a Mac

I have validated all my fonts with Font Book, I have cleared the cache (or so I believe) started in Safe mode and rebooted however I still get the same error. Any suggestions?


Charlie Stratton


3 Answers

Voted Best Answer

I don't think you have a bad font. Stastically, the odds of that are on par with getting struck by lighning and attacked by a shark, at the same time, on the beaches of Lake Michigan.

I'm not saying that it can't be it. I see hoof prints, let's look for horses - not zebras.

I think you have a bad tool that created the PDF. BBox errors tend to crop up when the PDF creation engine tries to do something 'stupid' to a font when creating the PDF. Such as, converting a generic Type-1 into a TrueType then from TrueType into a CID font before creating the PDF. Or, just their insertion of the font into the PDF contains buggy code. Or, just ignoring the BBox table completely (common on the really low-budget GDI based tools on the Windows side).

Yes, this can even be the case in MAC OS/X with the ubiquitus 'Save As PDF' feature everywhere - that uses the OS's PDF library (it's better now, but for a long while it was really, really bad).

Take a look at what created the PDF (File | Document Properties > Description section) - If it wasn't something safe and reliable (e.g. Acrobat) that very well may be the cause.

Rather than going to the extreme of reinstalling your OS (let's try to fix the squeeky door not by burning your house down but with a can of 3:1 oil) I would just see if refrying the PDF fixes it - Print the PDF back through the Adobe PDF printer and use one of the high-quality printer settings - such a.. High Quality. One of the settings that forces all fonts to be embedded.

Super Genius tools such as the preflight content viewer and WindJacks PDFCannopener can find out exactly what's wrong. Keep in mind these tools give a lot of very detailed, deep technical information on a PDF and take some time to learn how to use. Just letting you know that they are there - not asking you use them.

Hope this helps.

Doug


By Douglas Hanna   

As you're probably aware, Lucida Grande is a system level typeface installed when you install OS X, stored in System>Library>Fonts. As such, it cannot be disabled. It's possible that the font is damaged. The only thing that I can suggest is that you reinstall your OS which will - possible - replaced the damaged font with a 'new' copy.

Never seen this message before - but I can't think of any other solutions.

Clinton


Clinton Dyches   

I hate to say this - particularly since it's only one application that's giving you fits - but, if you've a backup, you made need to boot to your Recovery partition, erase your drive, and reinstall OS X. That should fix the font problem.

I've had no trouble with X or XI (although I've only been using XI since last Monday). It still seems to be that there's simply something wrong with Lucida Grande and not Acrobat Pro X.

If you've a Time Machine backup, reinstall the OS again, first erasing your hard drive. I would bet that X would work then (but get it working before you install XI, as I don't think that will fix the problem).

Clinton


Clinton Dyches   


Please specify a reason: