Live Cycle Designer ES - how do I remove a field from the tabbing order?

Form created in LiveCycle Designer 8; now using ES. How do I remove the calculated fields (Totals) from the tabbing order? This is not covered in the Help screens.
Windows, not Mac.


Vicky Curran


2 Answers

Voted Best Answer

I checked out the conversation at http://forums.adobe.com/message/2904843 (Ctrl-shift-click on the element). The answers were to:
1. Set a field to "protected" it won't show up in the tab order – accessed from the Value tab on the Object palette.

2. Use xfa.host.setFocus(fieldName); to explicitly force a jump to a particular field.


If the field is a "Text" not a "Text Field"; users cannot input to it. So there is no "Value tab" on the Object palette to change to "Protected". However, you can open the Tools menu, select Options, click on Tab Order and choose Only Show Tab Order for Fields. This takes non-input fields out of the tab order (regardless if the tab number is blue or tan).
If the field is a "Text Field", the Value Tab solution works.

I ran a search on my form's XML and did not find an instance of the second solution, so I didn't know where to place the code.

Doing both parts of solution 1 fixed the problem for my form.
Thanks for the help.


By Vicky Curran   

Take a look at this discussion, it has information about Designer 8: http://forums.adobe.com/message/2904843 (Ctrl-shift-click on the element).

Karl Heinz Kremer
PDF Acrobatics Without a Net
PDF Software Development, Training and More...
http://www.khkonsulting.com


Karl Heinz Kremer   


Please specify a reason: